Hi, we are currently evaluating Exalate for a possible Use-Case. I'm running into a strange issue atm. For explaination: We have Jira Datacenter on Prem, but there is currently no cluster. So I only have Jira Home and not Jira Shared Home. There is no cluster.properties-File. Anyway, in the System Info of the Jira Instance there is told that he path for Jira Home ist the same one as for Jira Shared Home: /var/atlassian/application-data/jira

I copied the example Script "BasicFieldSync.groovy" into <Jira Home>/scripts. In ScriptRunner I can see the Script in the Script-Editor.

Now I generated a Connection to our internal Jira from our external. I have an external one for Customer Support and an internal one for Devs. Currently both are pure testing-instances, not our productive ones. In the rules (visual mode) I added a Script-Rule and inserted the in the example suggested Code. See the example here: https://docs.exalate.com/docs/adding-basic-external-script

If I now run the sync I get this error: MissingPropertyException: No such property: BasicFieldSync for class: Script43

To me it seems that exalate does not find and load the external scripts. But I simply don't know why. I did everything like explained in the example, but it just doesn't work.

Can anyone help me with this?

Greetings, Marco

  1. Marco Kröger

    Update: As mentioned I have two instances. The new external one and a clone of the current productive internal one. On the clone of the internal one External Scripts ARE working. But still not in the external instance. So it may be something about the instance configuration. But I have no idea where to look at. The file-system-permissions look good and identical to the internal instance. The only difference I can examine ist that it seems the jira-username on the external instance is jira2 instad of jira. I don't know why it is that way. But I don't think this should be the issue.

CommentAdd your comment...

1 answer


    Hi, i solved the issue myself. As mentioned in the external instance the application-User was "jira2", not "jira". Using this manual (https://confluence.atlassian.com/jirakb/how-to-fix-directory-permissions-in-linux-for-jira-server-829048437.html) I switched the user in the user.sh, corrected Directory-Permissions as described and restarted Jira. After this external Scripts are working now. To be fair, maybe the restart solved the issue and not the user-change. But if the restart does not solve the issue for you, maybe have a look at the application-User.

    1. Javier Pozuelo

      Thanks for sharing your solution to the issue Marco!

    CommentAdd your comment...