Confluence has been updated to ver 6.15.9. In case of any troubles, please contact infra team.

API stability in minor version updates

 
1
0
-1
Hi, we're using the Exalate Plugin for On-Premise-Jira an ran into the problem that the API changed between versions 4.6.10-j8 and 4.6.12-j8. More specifically, the constructor of com.exalate.basic.domain.hubobject.v1.BasicHubIssueLink changed, which broke the script we were using for sychronization. Now, we're wondering whether such changes occur regularly in minor version updates so we can take that into account next time before switching to a new version of the plugin. Thanks in advance for your help. Cheers Johannes
    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      Hi Johannes,


      Unfortunately in the past we provided some scripts to our customers that were using internal APIs of our product (like the BasicHubIssueLink). This resulted in a problematic dependency that didn't allow us to perform some improvements in the product without changing some of this internal APIs. This is something that we are not doing anymore for the last months and now we make sure that every script provided to the customer won't be broke in the future by a release.


      If you are having any problem like this please open a ticket on our support and we will attend it with priority.


      Best regards,

      Juan

        CommentAdd your comment...